Invidious maintenance
Incident Report for Drivet
Resolved
This incident has been resolved.
Posted Jan 28, 2023 - 14:07 EET
Investigating
Invidious is currently in maintenance mode due to a server change. We are migrating data to other server temporarily as we are making major changes on our App Server
Posted Jan 28, 2023 - 13:57 EET