Unstable server connection
Incident Report for Drivet
Resolved
Fixed
Posted Dec 02, 2022 - 19:50 EET
Investigating
We are currently investigating this issue.
Posted Dec 02, 2022 - 15:51 EET